import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:.*?^0\\,){1}";
final String string = "\"REC01\",\n"
+ "\"Recipe1\",\n"
+ "10,\n"
+ "\"\",\n"
+ "\"\",\n"
+ "\" \",\n"
+ "2000,\n"
+ "\"0101\",\n"
+ "\" \",\n"
+ "\" \",\n"
+ "\"126\",\n"
+ "\"REC01\",\n"
+ "\" \",\n"
+ "0,\n"
+ "0,\n"
+ "5,\n"
+ "38.182,\"11200\",\"Ingredient1\",\" \",\" \",\"1\",\n"
+ "12.121,\"11800\",\"Ingredient2\",\" \",\" \",\"1\",\n"
+ "27.475,\"30910\",\"Ingredient3\",\" \",\" \",\"1\",\n"
+ "2.020,\"26200\",\"Ingredient4\",\" \",\" \",\"1\",\n"
+ "20.202,\"C01\",\"Ingredient5\",\" \",\" \",\"1\",\n"
+ "0,\n"
+ "\"REC02\",\n"
+ "\"Recipe2\",\n"
+ "10,\n"
+ "\"13/04/21\",\n"
+ "\"13/04/21\",\n"
+ "\" \",\n"
+ "1000,\n"
+ "\"0101\",\n"
+ "\" \",\n"
+ "\" \",\n"
+ "\"17\",\n"
+ "\"REC02\",\n"
+ "\" \",\n"
+ "0,\n"
+ "0,\n"
+ "3,\n"
+ "61.600,\"11200\",\"Ingredient1\",\" \",\" \",\"1\",\n"
+ "23.400,\"30910\",\"Ingredient3\",\" \",\" \",\"1\",\n"
+ "15.000,\"BR-F01\",\"Ingredient6\",\" \",\" \",\"1\",\n"
+ "0,\n"
+ "\"REC03\",\n"
+ "\"Recipe3\",\n"
+ "10,\n"
+ "\"19/03/21\",\n"
+ "\"19/03/21\",\n"
+ "\" \",\n"
+ "1000,\n"
+ "\"0103\",\n"
+ "\" \",\n"
+ "\" \",\n"
+ "\"28\",\n"
+ "\"REC03\",\n"
+ "\" \",\n"
+ "0,\n"
+ "0,\n"
+ "9,\n"
+ "64.450,\"11200\",\"Ingredient1\",\" \",\" \",\"1\",\n"
+ "12.700,\"30910\",\"Ingredient3\",\" \",\" \",\"1\",\n"
+ "2.000,\"20600\",\"Ingredient7\",\" \",\" \",\"1\",\n"
+ "12.000,\"27220\",\"Ingredient8\",\" \",\" \",\"1\",\n"
+ "0.320,\"584\",\"Ingredient9\",\" \",\" \",\"1\",\n"
+ "0.830,\"588\",\"Ingredient10\",\" \",\" \",\"1\",\n"
+ "0.050,\"599\",\"Ingredient11\",\" \",\" \",\"1\",\n"
+ "0.040,\"600\",\"Ingredient12\",\" \",\" \",\"1\",\n"
+ "7.610,\"585\",\"Ingredient13\",\" \",\" \",\"1\",\n"
+ "0,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}