use strict;
my $str = '/example/endpoint/here/34456dwf45
/endpoint/fddk449372
/434236/example/endpoint';
my $regex = qr~(^|/)[[:alpha:]]*[[:digit:]][[:alnum:]]*($|/)~mp;
my $subst = '\\1my_var\\2';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";