// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^|/)[[:alpha:]]*[[:digit:]][[:alnum:]]*($|/)").unwrap();
let string = "/example/endpoint/here/34456dwf45
/endpoint/fddk449372
/434236/example/endpoint";
let substitution = "\\1my_var\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}