import Foundation
let pattern = #"(^|/)[[:alpha:]]*[[:digit:]][[:alnum:]]*($|/)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/example/endpoint/here/34456dwf45
/endpoint/fddk449372
/434236/example/endpoint
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1my_var\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)