#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^|/)[[:alpha:]]*[[:digit:]][[:alnum:]]*(?![^\n/])"
Local $sString = "/example/endpoint/here/34456dwf45" & @CRLF & _
"/endpoint/fddk449372" & @CRLF & _
"/434236/example/endpoint"
Local $sSubst = "\1my_var\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)