package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[^\/]+)`)
var str = `Psycholinguistics/Theories_and_Models_
Java_Tutorial/Hello_World!
United_States_currency/$2_bill/dsfkljsd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}