#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?<=cachorro )corre\w+|(?<=cachorro )foi|(?<=cachorro )pul\w+)|((?<=gato )corre\w+|(?<=gato )foi|(?<=gato )dorm\w+)"
Local $sString = "O cachorro correu com o gato" & @CRLF & _
"O carro passou e o cachorro foi atrás" & @CRLF & _
"Sempre que chego em casa meu cachorro pula em mim" & @CRLF & _
"Ele foi correndo atrás do sonho" & @CRLF & _
"Enquanto o gato correu" & @CRLF & _
"O cachorro dormiu" & @CRLF & _
"Despois disso o gato dormiu"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")