use strict;
my $str = 'O cachorro correu com o gato
O carro passou e o cachorro foi atrás
Sempre que chego em casa meu cachorro pula em mim
Ele foi correndo atrás do sonho
Enquanto o gato correu
O cachorro dormiu
Despois disso o gato dormiu';
my $regex = qr/((?<=cachorro )corre\w+|(?<=cachorro )foi|(?<=cachorro )pul\w+)|((?<=gato )corre\w+|(?<=gato )foi|(?<=gato )dorm\w+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}