$re = '/^W(\d(\d(\d[A-Z]?)?)?)?$/m';
$str = 'W
W1
W12
W123
W123A
-- casos inválidos (tem que ter exatamente 3 dígitos antes do X, a regex não pega esses casos)
W1X
W12X';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);