re = /^W(\d(\d(\d[A-Z]?)?)?)?$/m
str = 'W
W1
W12
W123
W123A
-- casos inválidos (tem que ter exatamente 3 dígitos antes do X, a regex não pega esses casos)
W1X
W12X'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end