import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+\\.\\d*(*SKIP)(*FAIL)|(?!^)(?=(?:\\d{3})+(?!\\.|\\d))";
final String string = "123456789123456789123456789\n"
+ "123456789\n"
+ "1234567\n"
+ "123456781234567812345678.111111111111111\n"
+ "34.345";
final String subst = ",";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}