package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`'((?:[^'\\]|\\.)*asmx(?:[^'\\]|\\.)*)'`)
var str = `CCKeyUpDomReady('test.asmx/asdasd', 'QMlPJZTOH09XOPCcbB2jcg==', '0OO6h+G2Tzhr5XWj1Upg0A==', '0OO6h+G2Tzhr5XWj1Upg0A==', '/qqwweq2.asmx/qqq')`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}