# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/@([a-zA-Z]+)[^:]+:(\d+)!([AD])!->(\d+)//gm;t' <<< "PQ@Alderaa1:30000!A!->20000
@Cantonica:3000!D!->4000NM
"