#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)@([a-zA-Z]+)[^:]+:(\d+)!([AD])!->(\d+)"
Local $sString = "PQ@Alderaa1:30000!A!->20000" & @CRLF & _
"@Cantonica:3000!D!->4000NM" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)