// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)@([a-zA-Z]+)[^:]+:(\d+)!([AD])!->(\d+)").unwrap();
let string = "PQ@Alderaa1:30000!A!->20000
@Cantonica:3000!D!->4000NM
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}