$re = '/^element(?:(?!^element)[\s\S])+/m';
$str = 'element : 1
Description
This is the description of item 1
___________________
element : 2
Description
This is the description of item 2
______________________';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);