const regex = /^([^;]+);([^;]+);((?:\d{4}|\?{4})-(?:\d\d|\?{2})-(?:\d\d|\?{2}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^;]+);([^;]+);((?:\\d{4}|\\?{4})-(?:\\d\\d|\\?{2})-(?:\\d\\d|\\?{2}))$', 'gm')
const str = `bla;blubb;1234-45-34
sfsdf;sdfsf;2432-09-??
sffd;sdfsd;3423-??-??
df sdf; sdd sd sssssfdsw;????-??-??`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}