re = /^([^;]+);([^;]+);((?:\d{4}|\?{4})-(?:\d\d|\?{2})-(?:\d\d|\?{2}))$/m
str = 'bla;blubb;1234-45-34
sfsdf;sdfsf;2432-09-??
sffd;sdfsd;3423-??-??
df sdf; sdd sd sssssfdsw;????-??-??'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end