import Foundation
let pattern = #"^([^;]+);([^;]+);((?:\d{4}|\?{4})-(?:\d\d|\?{2})-(?:\d\d|\?{2}))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
bla;blubb;1234-45-34
sfsdf;sdfsf;2432-09-??
sffd;sdfsd;3423-??-??
df sdf; sdd sd sssssfdsw;????-??-??
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)