#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?=[5KL]) # первый символ 5 или K или L" & @CRLF & _
"(?=..{,49}\d) # должна быть хотя бы одна цифра" & @CRLF & _
"(?=..{,49}[a-z]) # должна быть хотя бы одна строчная буква" & @CRLF & _
"(?=..{,49}[A-Z]) # должна быть хотя бы одна заглавная буква" & @CRLF & _
"[a-zA-Z0-9]{51} # 51 цифра или буква, а условия указаны ранее"
Local $sString = "aaa5KXH6bXuyX7xDUiNDiyX2VqvePBqpAJWuKDypJBZeS9qPf3LNGJaaa // просто поиск" & @CRLF & _
"aaa5eeeeeeeEEEeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeaaa // внутри нет цифр" & @CRLF & _
"// если 5 в начале подходит для условия наличия цифр, то не .{,49}, а {,50}" & @CRLF & _
"aaa5eeeeeeeeeeeeeeee1eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeaaa // нет заглавных" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")