package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[[:alnum:]]+/[[:alnum:]]+\)(?:-[[:alnum:]]+){3}`)
var str = `[[1]]
abc/a3d)-1-B-3-B
[[2]]
dec/d93)-B-1-3
[[3]]
vdiek/asdf899)-1-B-B-B-1-3-4
[[4]]
avd/asd/vde)-1-B-3-4
[[5]]
ab33/dfv)-B-12-B
[[6]]
abc/ade)-1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}