use strict;
my $str = '[[1]]
abc/a3d)-1-B-3-B
[[2]]
dec/d93)-B-1-3
[[3]]
vdiek/asdf899)-1-B-B-B-1-3-4
[[4]]
avd/asd/vde)-1-B-3-4
[[5]]
ab33/dfv)-B-12-B
[[6]]
abc/ade)-1
';
my $regex = qr`^[[:alnum:]]+/[[:alnum:]]+\)(?:-[[:alnum:]]+){3}`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}