import Foundation
let pattern = #"^[[:alnum:]]+/[[:alnum:]]+\)(?:-[[:alnum:]]+){3}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[[1]]
abc/a3d)-1-B-3-B
[[2]]
dec/d93)-B-1-3
[[3]]
vdiek/asdf899)-1-B-B-B-1-3-4
[[4]]
avd/asd/vde)-1-B-3-4
[[5]]
ab33/dfv)-B-12-B
[[6]]
abc/ade)-1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)