import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SELECT [\\w\\s\\(\\*\\)\\,]* FROM ticket_file [\\w\\s\\\"\\'\\`\\<\\>\\=]*";
final String string = "SELECT * FROM ticket_file WHERE 1\n\n"
+ "SELECT id, name FROM ticket_file WHERE id < 100\n\n"
+ "SELECT COUNT(*) FROM ticket_file\n\n"
+ "SELECT MAX(id) FROM ticket_file";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}