import re
regex = re.compile(r"SELECT [\w\s\(\*\)\,]* FROM ticket_file [\w\s\"\'\`\<\>\=]*", flags=re.MULTILINE)
test_str = ("SELECT * FROM ticket_file WHERE 1\n\n"
"SELECT id, name FROM ticket_file WHERE id < 100\n\n"
"SELECT COUNT(*) FROM ticket_file\n\n"
"SELECT MAX(id) FROM ticket_file")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")