$re = '/([\w\s]+)\s+[\u2192]\s+([\w\s;:]+)/m';
$str = 'brow fox → jumps over the lazy dog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);