re = /(^|[^a-z])month/m
str = 'startmonth month +month'
subst = '\\112'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result