$re = '/^(?!(?:[^\d\s]*\d){2})[\w@#$]+$/m';
$str = 'ab3c
a@bc
a@1c
4
a2
Test12
12
1test3
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);