using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!(?:\w*(\w)\1){3})\w+\b";
string input = @"adminnisstrator21
kkeeykloakk
stack22ooverflow
blahbllahhblaafaa
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}