re = /(?:\G(?!^)\h+|\bexcept\h+)\K\w+/
str = ' wholesale trade except motor vehicles motorcycles
retail trade except motor vehicles motorcycles'
subst = 'MATCH'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result