$re = '/^(\s*"Version"\s*:\s*")[^"]*/m';
$str = '{
"FramewokSettings": {
"Name": "VX",
"Version": "8", // The value here is not constant. It can be something like v1.4.56.456 also
"GitVersion": "v5",
"DatabaseVersion": "7",
// Doing xyz
"CounterVersion": "2"
// Doing ABC.
// Start
}
}';
$subst = "${1}10";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;