$re = '/\d+\D+(\d+\s*\w+)/m';
$str = '1 - hello world 1234 abc 5678 def';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);