$re = '/(<row.*Body=").*?("[^>]+>)/';
$str = '<row Id="9" Body="aaaaaaaaa" Target="123456" />';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;