import Foundation
let pattern = #"(<row.*Body=").*?("[^>]+>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<row Id="9" Body="aaaaaaaaa" Target="123456" />"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)