$re = '/\n{2,}/m';
$str = 'var массив = [
1
]';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;