import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:\\d){1,3}(?:\\.\\d{1,3}){0,8})";
final String string = "1 text\n"
+ "1.1 text 2\n"
+ "1.2 text 3\n"
+ "2 text 2\n"
+ "3 text 3\n"
+ "3.1 text 3.1\n"
+ "second string of 3.1\n"
+ "third string of 3.1\n"
+ "4.1.2.3.4.5\n"
+ "4.1.2.3.4.5.6.7.8\n\n\n"
+ "//I used .split() method to get multiline text from numbered list";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}