using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!'{NSVue)(.)*(')$";
string substitution = @"";
string input = @"'getFrameById() is deprecated. Use Frame.getFrameById() instead.'
'{NSVue (Vue: 2.6.10 | NSVue: 2.4.0)} -> CreateElement(NativePage)'
'{NSVue (Vue: 2.6.10 | NSVue: 2.4.0)} -> CreateElement(NativeActionBar)'
'{NSVue (Vue: 2.6.10 | NSVue: 2.4.0)} -> CreateElement(nativenavigationbutton)'
'{NSVue (Vue: 2.6.10 | NSVue: 2.4.0)} -> AppendChild(ElementNode(nativeactionbar), ElementNode(nativenavigationbutton))'
'{NSVue (Vue: 2.6.10 | NSVue: 2.4.0)} -> CreateElement(nativeactionitem)'
'{NSVue (Vue: 2.6.10 | NSVue: 2.4.0)} -> AppendChild(ElementNode(nativeactionbar), ElementNode(nativeactionitem))'";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}