const regex = /^(?!'{NSVue)(.)*(')$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\'{NSVue)(.)*(\')$', 'gm')
const str = `'getFrameById() is deprecated. Use Frame.getFrameById() instead.'
'{NSVue (Vue: 2.6.10 | NSVue: 2.4.0)} -> CreateElement(NativePage)'
'{NSVue (Vue: 2.6.10 | NSVue: 2.4.0)} -> CreateElement(NativeActionBar)'
'{NSVue (Vue: 2.6.10 | NSVue: 2.4.0)} -> CreateElement(nativenavigationbutton)'
'{NSVue (Vue: 2.6.10 | NSVue: 2.4.0)} -> AppendChild(ElementNode(nativeactionbar), ElementNode(nativenavigationbutton))'
'{NSVue (Vue: 2.6.10 | NSVue: 2.4.0)} -> CreateElement(nativeactionitem)'
'{NSVue (Vue: 2.6.10 | NSVue: 2.4.0)} -> AppendChild(ElementNode(nativeactionbar), ElementNode(nativeactionitem))'`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);