using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\'{3}(?:[^\\]|\\[\s\S])*(?:\'{3}$))";
string input = @"''' 'This ""is"" my' && ""first 'regex' sentence."" ''' &&
''' 'This ""is"" the second.' '''
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}