re = /(^\'{3}(?:[^\\]|\\[\s\S])*(?:\'{3}$))/m
str = '\'\'\' \'This "is" my\' && "first \'regex\' sentence." \'\'\' &&
\'\'\' \'This "is" the second.\' \'\'\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end