#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\d*000)\d+$"
Local $sString = "001234567502344001233400122300" & @CRLF & _
"0123456750023440012334012230" & @CRLF & _
"000123456750234400123340012230" & @CRLF & _
"001234567502344000123340012230" & @CRLF & _
"0012345675023440012334001223000" & @CRLF & _
"00123456750234400012334001223000" & @CRLF & _
"001002003004005006" & @CRLF & _
"000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")