re = /^(?!\d*000)\d+$/m
str = '001234567502344001233400122300
0123456750023440012334012230
000123456750234400123340012230
001234567502344000123340012230
0012345675023440012334001223000
00123456750234400012334001223000
001002003004005006
000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end