#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(?:[^\d\n]*\d){0,12}[^\d\n]*$)\d*[.]?\d{0,6}$"
Local $sString = "1.22" & @CRLF & _
"1.234567" & @CRLF & _
"123456789012" & @CRLF & _
"1234567.9012" & @CRLF & _
"123456789012" & @CRLF & _
"" & @CRLF & _
"1234567890123" & @CRLF & _
"1.2345678"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")