using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(?:[^\n\d]*\d){13})\d*[.]?\d{0,6}$";
string input = @"1.22
1.234567
123456789012
1234567.9012
123456789012
1234567890123
1.2345678";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}