#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([\w\d._-]+)(\.jar)$"
Local $sString = "server.jar" & @CRLF & _
"invalid&name.jar" & @CRLF & _
"another_valid-one.jar" & @CRLF & _
"1is.valid.jar" & @CRLF & _
"not-valid.jar.zip"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")