using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\w\d._-]+)(\.jar)$";
string input = @"server.jar
invalid&name.jar
another_valid-one.jar
1is.valid.jar
not-valid.jar.zip";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}