const regex = /^([\w\d._-]+)(\.jar)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\w\\d._-]+)(\\.jar)$', 'mg')
const str = `server.jar
invalid&name.jar
another_valid-one.jar
1is.valid.jar
not-valid.jar.zip`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}