$re = '/^([\w\d._-]+)(\.jar)$/m';
$str = 'server.jar
invalid&name.jar
another_valid-one.jar
1is.valid.jar
not-valid.jar.zip';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);