re = /^([\w\d._-]+)(\.jar)$/m
str = 'server.jar
invalid&name.jar
another_valid-one.jar
1is.valid.jar
not-valid.jar.zip'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end