const regex = /(?i:([;]|^)([a-z0-9.]+@(dom\.net|part1\.part2\.uk))(?=[;]|$))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i:([;]|^)([a-z0-9.]+@(dom\\.net|part1\\.part2\\.uk))(?=[;]|$))', 'g')
const str = `a.name@part1.part2.uk;a.name@dom.net`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}